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1. Σκοπός 

Το AWR Design Environment (AWRDE) είναι ένα προηγμένο περιβάλλον προσομοίωσης και 
μοντελοποίησης τηλεπικοινωνιακών συστημάτων. Στην παρούσα εργαστηριακή άσκηση 
γίνεται εισαγωγή στην λειτουργία του περιβάλλοντος με στόχο την εξοικείωση των 
φοιτητών με την διεπαφή χρήστη του λογισμικού. 

 

2. Προσδοκώμενα αποτελέσματα 

Όταν θα έχετε ολοκληρώσει την παρούσα εργαστηριακή άσκηση, θα μπορείτε να: 

 Γνωρίζετε τα δομικά τμήματα ενός QPSK πομπού.  

 Παραμετροποιείτε τις παραμέτρους των τμημάτων ενός QPSK πομπού.  

 Λαμβάνετε μετρήσεις σε όποιο σημείο επιθυμείτε από την τηλεπικοινωνιακή 

αλυσίδα  

 Προσομοιώνετε την λειτουργία ενός QPSK διαμορφωτή 

 

3. Τι θα χρειαστείτε 

Για την επιτυχή εκτέλεση της άσκησης θα χρειαστείτε τα παρακάτω: 

• Η/Υ με εγκατεστημένο το λογισμικό AWR 10.08 

 

4. Έννοιες κλειδιά 

• Σήμα 

• Συχνότητα 

• Κυματομορφή 

• Διαμόρφωση Πλάτους 

• Δείκτης Διαμόρφωσης 

 

5. Εισαγωγικές Παρατηρήσεις 

Μια ενδιαφέρουσα περίπτωση των διαμορφώσεων φάσης πολλαπλών επιπέδων είναι η 
διαμόρφωση μετατόπισης φάσης με τετραγωνισμό 
(Quadrature PSK, QPSK), η οποία χρησιμοποιεί τέσσερα 
σύμβολα, ορθογωνικά μεταξύ τους.  

Το διάγραμμα αστερισμού της QPSK αποτελείται από 4 
σημεία επάνω σε έναν κύκλο ακτίνας Α (= πλάτος 
φέροντος), τα οποία ισαπέχουν μεταξύ τους κατά γωνία π/2 
rad. Οι καταστάσεις φάσεων είναι στραμμένες κατά 45ο ως 
προς τους δύο άξονες 𝑐𝑜𝑠(𝜔𝐶𝑡) και 𝑠𝑖𝑛⁡(𝜔𝐶𝑡). 

 

 

http://en.wikipedia.org/wiki/Phase-shift_keying
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Η QPSK λόγω της ορθογωνικότητας επιτυγχάνει διπλάσια ταχύτητα από την BPSK στο ίδιο 
εύρος ζώνης και χωρίς να υποβαθμίζεται η απόδοση ανίχνευσης.  

Η φασματική απόδοση της QPSK είναι διπλάσια από της BPSK, δηλαδή είναι 𝑸 =

𝟐 𝒃𝒊𝒕/𝒔/𝑯𝒛  

 

Διαμορφωτής QPSK 

Τα δεδομένα εισόδου χωρίζονται σε δύο ακολουθίες (μία άρτια και μία περιττή), οι οποίες 
εμφανίζουν ρυθμό δεδομένων το ήμισυ του αρχικού ρυθμού.  

Οι ακολουθίες φιλτράρονται και διαμορφώνουν κατά BPSK δύο ορθογωνικά φέροντα  

𝑐𝑜𝑠(𝜔𝐶𝑡) και 𝑠𝑖𝑛⁡(𝜔𝐶𝑡) τα οποία αθροίζονται παράλληλα. 

 

Διάγραμμα διαμορφωτή QPSK 

 

Αποδιαμορφωτής QPSK 

Το διαμορφωμένο σήμα: 

 Υφίσταται μίξη με τα δύο ορθογωνικά φέροντα, τα οποία έχουν προηγουμένως 
ανακτηθεί.  

 Οδηγείται σε ένα συγκριτή προκειμένου να ανακτηθούν οι δύο ακολουθίες 
δεδομένων.  

Τα δεδομένα  ανασυντίθενται σε μια ενιαία ακολουθία με τη χρήση κατάλληλου  
μετατροπέα παράλληλης επικοινωνίας σε σειριακή.  

 

Διάγραμμα αποδιαμορφωτή QPSK 

Ένας σύμφωνος δέκτης QPSK απαιτεί ακριβή ανάκτηση του φέροντος. Είναι δυνατό να 
χρησιμοποιηθούν οι ίδιες μέθοδοι ανάκτησης του χρονισμού των συμβόλων, με αυτές που 
περιγράφηκαν στις μεθόδους διαμόρφωσης βασικής ζώνης και την δυαδική PSK. 
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6. Πείραμα: Διαμόρφωση Φάσης QPSK 

Οι δραστηριότητες στο παρόν παράδειγμα περιλαμβάνουν: 

1. Τη δημιουργία ενός νέου έργου (Project) 
2. Τον ορισμό προκαθορισμένων ρυθμίσεων συστήματος 
3. Τη δημιουργία ενός διαγράμματος συστήματος (system block) 
4. Την προσθήκη ηλεκτρονικών στοιχείων (blocks) στο διάγραμμα συστήματος 
5. Τον ορισμό των παραμέτρων προσομοίωσης  
6. Την προσθήκη γραφημάτων και μετρήσεων  
7. Την εκτέλεση της προσομοίωσης και την ανάλυση των αποτελεσμάτων 

 

6.1 Δημιουργία Project 

Βήμα 1ο:  Πάμε στο File > New Project 

Βήμα 2ο:  Επιλέγουμε File > Save Project As. Το παράθυρο διαλόγου Save As εμφανίζεται 

Βήμα 3ο:  Επιλέγουμε τον φάκελο στον οποίο θέλουμε να αποθηκεύσουμε το Project. 

Βήμα 4ο:  Δίνουμε μία ονομασία της επιλογής μας, π.χ. “Basic_QPSK_BER” το νέο Project, 
στο παράθυρο διαλόγου που εμφανίζεται. Αποθηκεύουμε πατώντας Save. 

Σημείωση: Συνίσταται να αποθηκεύουμε κάθε νέο Project σε ξεχωριστό φάκελο. 

 

6.2 Ορισμός καθολικών ρυθμίσεων συστήματος 

Πριν δημιουργήσουμε μια προσομοίωση πρέπει να ορίσουμε τις καθολικές ρυθμίσεις του 
συστήματος. Για να τις ορίσουμε κάνουμε τα εξής βήματα: 

• Από το οριζόντιο μενού επιλέγουμε Options > Project Options 

• Πηγαίνουμε στην καρτέλα Global Units και επιβεβαιώνουμε ότι οι ρυθμίσεις 
αντιστοιχούν με αυτές που δίνονται στην Εικόνα 3. 

• Πατάμε ΟΚ για να αποθηκεύσουμε τις ρυθμίσεις. 

 

Εικόνα 3 – Ορισμός προκαθορισμένων ρυθμίσεων συστήματος 
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6.3 Δημιουργία διαγράμματος συστήματος 

Το διάγραμμα συστήματος είναι το πλέον βασικό τμήμα του περιβάλλοντος εργασίας, 
καθώς αποτελεί τον καμβά στον οποίο χτίζουμε εξ’ ολοκλήρου (end-to-end) τα  συστήματα 
επικοινωνιών και υλοποιούμε αλγορίθμους με γραφικό τρόπο χρησιμοποιώντας τα block 
συμπεριφοράς (behavioral blocks) του VSS. Ένα VSS project μπορεί να περιλαμβάνει 
πολλαπλά διαγράμματα συστήματος, γραμμικά και μη-γραμμικά σχηματικά, και netlists. 

Για να δημιουργήσουμε ένα διάγραμμα συστήματος: 

• Επιλέγουμε Project > Add System Diagram > New System Diagram. Εμφανίζεται το 
παράθυρο διαλόγου του νέου διαγράμματος συστήματος 

• Πληκτρολογούμε “QPSK Quadrature” και πατάμε Create. Ένα παράθυρο διαγράμματος 
συστήματος εμφανίζεται στον χώρο εργασίας (workspace) και το “QPSK Quadrature” 
διάγραμμα συστήματος εμφανίζεται κάτω από τα System Diagrams στον πλοηγό Project 
(βλ. Εικόνα 4). 

 

Εικόνα 4 – Διάγραμμα συστήματος 

 

6.4 Προσθήκη Block στο διάγραμμα συστήματος 

Ο κατάλογος στοιχείων (elements catalog) είναι μία βάση που περιέχει πολλά δομικά 
μπλοκ (ηλεκτρικά/ ηλεκτρονικά στοιχεία), τα οποία μπορούν να χρησιμοποιηθούν στα 
διαγράμματα συστήματος ώστε να συνθέσουμε ένα σύστημα ή έναν αλγόριθμο 
επικοινωνίας. 

Για να τοποθετήσουμε ένα μπλοκ στο διάγραμμα συστήματος ακολουθούμε τα εξής 
βήματα: 

• Πατάμε στην καρτέλα Elements (κάτω αριστερά) ώστε να εμφανιστεί ο κατάλογος 
στοιχείων 

• Πατάμε στο σύμβολο + αριστερά του System Block για να επεκτείνουμε το δέντρο 
του καταλόγου. 

• Επιλέγουμε την κατηγορία Sources. 
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• Επεκτείνουμε την κατηγορία Sources και από την υποκατηγορία Random 
επιλέγουμε το RND_D block και το τοποθετούμε στο διάγραμμα συστήματος όπως  
φαίνεται στην Εικόνα5 

•  

Εικόνα 5 –Τοποθέτηση του RND_D Block στο διάγραμμα συστήματος 

 

• Επεκτείνουμε την κατηγορία Converters, επιλέγουμε την υποκατηγορια Binary και 
επιλεγουμε το B2SYM block το οποίο προσθέτουμε στο διάγραμμα συστήματος 

• Επεκτείνουμε την κατηγορία Converters, επιλέγουμε την υποκατηγορία Data Type. 
Επιλέγουμε το D2R block και το προσθέτουμε στο διάγραμμα συστήματος 

• Επιλέγουμε απο την κατηγορια Math Tools, το Scale block στο διάγραμμα 
συστήματος. 

• Επιλέγουμε απο την κατηγορια Math Tools, το Cosine block στο διάγραμμα 
συστήματος 

• Επιλέγουμε απο την κατηγορια Math Tools, το Sine block στο διάγραμμα 
συστήματος 

• Επιλέγουμε απο την κατηγορια Signal Processing, το Hold block στο διάγραμμα 
συστήματος 

• Επιλέγουμε απο την κατηγορια Filters, το PLSSHP block στο διάγραμμα συστήματος 

• Επεκτείνουμε την κατηγορία Converters, επιλέγουμε την υποκατηγορία Data Type. 
Επιλέγουμε το RI2C block και το προσθέτουμε στο διάγραμμα συστήματος 

• Επιλέγουμε απο την κατηγορια Signal Processing, το PHASE block στο διάγραμμα 
συστήματος 

• Επιλέγουμε απο την κατηγορια Channels, το AWGN block στο διάγραμμα 
συστήματος 

• Επεκτείνουμε την κατηγορία Converters, επιλέγουμε την υποκατηγορία Data Type. 
Επιλέγουμε το CI2R block και το προσθέτουμε στο διάγραμμα συστήματος 
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• Επιλέγουμε απο την κατηγορια Signal Processing, το DECIM block στο διάγραμμα 
συστήματος 

• Επεκτείνουμε την κατηγορία Modulation, επιλέγουμε την υποκατηγορία QPSK. 
Επιλέγουμε το QPSK_DET block και το προσθέτουμε στο διάγραμμα συστήματος 

• Επιλέγουμε απο την κατηγορια Signal Processing, το ALIGN block στο διάγραμμα 
συστήματος 

• Επεκτείνουμε την κατηγορία Meters, επιλέγουμε την υποκατηγορία BER. 
Επιλέγουμε το BER block και το προσθέτουμε στο διάγραμμα συστήματος 

• Επιλέγουμε απο την κατηγορια Meters, το TP  block στο διάγραμμα συστήματος 

• Για κάθε ένα από τα block (Hold-PLSSHP-RI2C-DESIM-TP) τα επιλέγουμε ξεχωριστά 
και κάνοντας copy-paste δημιουργούμε ίδια block τόσες φορές όσες χρειάζεται 
όπως φαίνεται στο διάγραμμα συστήματος στην εικόνα  

• Πάμε File > Save Project. 

Το διάγραμμα συστήματος πρέπει να φαίνεται όπως στην Εικόνα 6 

 

Εικόνα 6 – Διάγραμμα συστήματος 

 

6.5 Ορισμός των Παραμέτρων Προσομοίωσης 

Για να ορίσουμε τις παραμέτρους προσομοίωσης κάνουμε τα παρακάτω βήματα: 

• Επιλέγουμε Options > Default System Options. Το παράθυρο διαλόγου των 
παραμέτρων προσομοίωσης εμφανίζεται. 

• Πάμε στην καρτέλα Simulator και κάτω από το Sampling Frequencies / Data Rates 
επιλέγουμε Data rate στο πρώτο drop-down μενού και Oversampling στο δεύτερο 
drop-down μενού. 

• Θέτουμε “1” GHz το Data rate και 8 την τιμή του Oversampling (Εικόνα 7). Πατάμε 
OK. 
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Εικόνα 7 – Ιδιότητες προσομοιωτή συστήματος 

 

6.6 Δημιουργία γραφήματος 

O VSS επιτρέπει να δούμε τα αποτελέσματα μιας προσομοίωσης με διάφορα γραφήματα. 
Πριν εκτελέσουμε μια προσομοίωση πρέπει να δημιουργήσουμε ένα γράφημα και να 
καθορίσουμε τα δεδομένα και τις παραμέτρους που επιθυμούμε να απεικονίσουμε. 

Για να δημιουργήσουμε ένα γράφημα κάνουμε τα ακόλουθα βήματα: 

• Πάμε στην καρτέλα Project (κάτω αριστερά), ώστε να εμφανίσουμε τον πλοηγό 
Project. 

• Κάνουμε δεξί click στην κατηγορία Graphs και επιλέγουμε New Graph. Το 
παράθυρο διαλόγου New Graph εμφανίζεται. Δίνουμε όνομα της επιλογής μας, π.χ. 
“ΒΕR”, επιλέγουμε Rectangular σαν τύπο γραφήματος και πατάμε Create. 

• Το γράφημα εμφανίζεται στον χώρο εργασίας και σαν καταχώρηση κάτω από την 
κατηγορία Graphs στον πλοηγό Project . 

• Με τον ίδιο τρόπο δημιουργούμε τα γραφήματα Eye at output of QPSK 
Quadrature, Scatter Plot και Spectrum. 

 

6.7 Προσθήκη μέτρησης 

Για να προσθέσουμε μια μέτρηση στο γράφημα που δημιουργήσαμε ακολουθούμε τα 
παρακάτω βήματα: 

• Κάνουμε δεξί click στο γράφημα “BER” στον πλοηγό Project, και επιλέγουμε Add 
Measurement. Το παράθυρο διαλόγου του Add Measurement εμφανίζεται (Εικόνα 
8). 
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Εικόνα 8 - Προσθήκη μέτρησης στο γράφημα BER 

 

• Κάνουμε δεξί click στο γράφημα “Eye at output of QPSK Quadrature” στον πλοηγό 
Project, και επιλέγουμε Add Measurement. Το παράθυρο διαλόγου του Add 
Measurement εμφανίζεται (Εικόνα 9) 

 

 

Εικόνα 9 - Προσθήκη μέτρησης στο γράφημα Eye at output of QPSK Quadrature 
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• Κάνουμε δεξί click στο γράφημα “Scatter Plot” στον πλοηγό Project, και επιλέγουμε 
Add Measurement. Το παράθυρο διαλόγου του Add Measurement εμφανίζεται 
(Εικόνα 10) 

 

Εικόνα 10- Προσθήκη μέτρησης στο γράφημα Scatter Plot 

 

• Κάνουμε δεξί click στο γράφημα “Scatter Plot” στον πλοηγό Project, και επιλέγουμε 
Add Measurement. Το παράθυρο διαλόγου του Add Measurement εμφανίζεται 
(Εικόνα 11) 

 

Εικόνα 11- Προσθήκη μέτρησης στο γράφημα Spectrum 

 

Επιλέγουμε στο Test Point TP.OUT1  και πατάμε Apply. Κάνουμε το ίδιο για TP.OUTBITS. 
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7.8 Εκτέλεση Προσομοίωσης 

Μετά την επιτυχή υλοποίηση όλων των παραπάνω βημάτων, είμαστε πλέον έτοιμοι να 
θέσουμε σε λειτουργία την προσομοίωση του συστήματος. Για το σκοπό αυτό επιλέγουμε: 

• Simulate > Run/Stop System Simulators. Αφήνουμε την προσομοίωση να τρέξει για 
5 δευτερόλεπτα και στη συνέχεια την διακόπτουμε με την επιλογή Simulate > 
Run/Stop Simulators. Το αποτέλεσμα της προσομοίωσης πρέπει να φαίνεται στο 
γράφημα όπως στην Εικόνα 12. 
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7. Λίστα ελέγχου γνώσεων 

Αφού ολοκληρώσατε την εκτέλεση της παρούσας εργαστηριακής άσκησης, επιστρέψτε στα 

αρχικά προσδοκώμενα αποτελέσματα και ελέγξτε κατά πόσο: 

 Γνωρίζετε τα δομικά τμήματα ενός QPSK εκπομπού;  
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 Μπορείτε να παραμετροποιήσετε τις παραμέτρους των τμημάτων ενός QPSK 

εκπομπού;  

 Μπορείτε να λάβετε μετρήσεις σε όποιο σημείο επιθυμείτε από την 

τηλεπικοινωνιακή αλυσίδα QPSK  

 Μπορείτε να προσομοιώνετε την λειτουργία ενός QPSK διαμορφωτή;. 
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9. Χρήσιμοι σύνδεσμοι 

1. https://awrcorp.com/download/faq/english/docs/Getting_Started/ 

2. http://www.awrcorp.com/awrtv-player 

3. http://el.wikipedia.org/wiki/Διαμόρφωση_μετατόπισης_συχνότητας  
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