
 
 

 
 

ΤΕΧΝΟΛΟΓΙΚΟ ΕΚΠΑΙΔΕΥΤΙΚΟ ΙΔΡΥΜΑ ΔΥΤΙΚΗΣ ΕΛΛΑΔΑΣ 

ΤΜΗΜΑ ΜΗΧΑΝΙΚΩΝ ΠΛΗΡΟΦΟΡΙΚΗΣ Τ.Ε. 

 

 

ΤΗΛΕΠΙΚΟΙΝΩΝΙΑΚΑ ΣΥΣΤΗΜΑΤΑ ΙI 
ΕΡΓΑΣΤΗΡΙΑΚΟΣ ΟΔΗΓΟΣ 

 
Εργαστηριακή Άσκηση 3 

Παλμοκωδική Αποδιαμόρφωση σήματος 

 
 

Δρ. Μιχάλης Παρασκευάς 

Επίκουρος Καθηγητής 

Βασίλειος Τσακανίκας – Χρήστος Τσίνος 

Πανεπιστημιακοί Υπότροφοι 

 
 

 

Μάρτιος 2015



Άσκηση 3: «Παλμοκωδική Αποδιαμόρφωση σήματος» 
 

1 

 

Πίνακας περιεχομένων 
1. Σκοπός ............................................................................................................................... 2 

2. Προσδοκώμενα αποτελέσματα ....................................................................................... 2 

3. Τι θα χρειαστείτε .............................................................................................................. 2 

4. Έννοιες κλειδιά ................................................................................................................. 2 

5. Εισαγωγικές Παρατηρήσεις ............................................................................................. 2 

6. Πείραμα: Παλμοκωδική αποδιαμόρφωση ..................................................................... 3 

6.1 Δημιουργία Project ......................................................................................................... 3 

6.2 Ορισμός καθολικών ρυθμίσεων συστήματος ................................................................. 3 

6.3 Δημιουργία διαγράμματος συστήματος ......................................................................... 4 

6.4 Προσθήκη των δομικών στοιχείων (Blocks) στο διάγραμμα συστήματος (Ι) ................. 5 

6.5 Προσθήκη των δομικών στοιχείων (Blocks) στο διάγραμμα συστήματος (ΙΙ) ................ 5 

6.5.1 Κανάλι μετάδοσης .................................................................................................... 6 

6.5.2 Κεραία Λήψης........................................................................................................... 6 

6.5.3 Αποδιαμορφωτής σήματος (D2R) ............................................................................ 6 

6.5.4 Κατασκευαστής κβαντικού σήματος ........................................................................ 7 

6.5.5  Ανακατασκευαστής σήματος (DAC) ........................................................................ 7 

6.5.6 Προσομοιωτής προσθήκης DC συνιστώσας ............................................................ 7 

6.5.7 Χαμηλοδιαβατό φίλτρο ............................................................................................ 8 

6.5.8 Συνδεσμολογία αλυσίδας ........................................................................................ 8 

6.5.9 Σημεία μέτρησης ...................................................................................................... 8 

7. Δραστηριότητες .............................................................................................................. 11 

8. Λίστα ελέγχου γνώσεων ................................................................................................. 11 

9. Βιβλιογραφία-Οδηγός για περαιτέρω μελέτη .............................................................. 11 

10. Χρήσιμοι σύνδεσμοι ................................................................................................... 11 

 

 

 

Έκδοση:   1.0 

Επιμέλεια φυλλαδίου: Βασίλειος Τσακανίκας και Παρασκευάς Μιχάλης 

  



Άσκηση 3: «Παλμοκωδική Αποδιαμόρφωση σήματος» 
 

2 

 

1. Σκοπός 

Σκοπός της παρούσας εργαστηριακής άσκησης είναι να μελετηθεί η παλμοκωδική 
αποδιαμόρφωση ψηφιακού σήματος με την βοήθεια του λογισμικού προσομοίωσης AWR. 
Στην παρούσα φάση θα δοθεί έμφαση στο τμήμα του δέκτη PCM. Το κύκλωμα της 
εργαστηριακής άσκησης 2 θεωρείται γνωστό και θα πρέπει να κατασκευαστεί εκ νέου πριν 
την έναρξη της παρούσας εργαστηριακής άσκησης. 

 

2. Προσδοκώμενα αποτελέσματα 

Όταν θα έχετε ολοκληρώσει την παρούσα εργαστηριακή άσκηση, θα: 

 Γνωρίζετε τα δομικά τμήματα ενός PCM δέκτη. 

 Παραμετροποιείτε τις παραμέτρους των τμημάτων ενός PCM δέκτη. 

 Λαμβάνετε μετρήσεις σε όποιο σημείο επιθυμείτε από την τηλεπικοινωνιακή 
αλυσίδα. 

 Προσομοιώνετε την λειτουργία ενός PCM αποδιαμορφωτή. 

 

3. Τι θα χρειαστείτε 

Για την επιτυχή εκτέλεση της άσκησης θα χρειαστείτε τα παρακάτω: 

 Η/Υ με εγκατεστημένο το λογισμικό AWR 10.08 

 

4. Έννοιες κλειδιά 

 Παλμοκωδική αποδιαμόρφωση 

 Αποκωδικοποίηση 

 Κβαντοποίηση  

 Ανακατασκευή σήματος 

 

5. Εισαγωγικές Παρατηρήσεις 

Οι βασικές επεξεργασίες στην παλμοκωδική αποδιαμόρφωση PCM είναι η 

Αποδιαμόρφωση, η Αποκωδικοποίηση και η Ανακατασκευή του σήματος. 

 

 

 

Σχήμα 1: Βασικές επεξεργασίες στην παλμοκωδική αποδιαμόρφωση PCM 

Κατά την φάση της αποδιαμόρφωσης, ο δέκτης λαμβάνει την ροή από bits και αποφασίζει 

για κάθε bit την τιμή του, ελέγχοντας το επίπεδο ισχύος του κάθε παλμού. Αυτό είναι και το 

στάδιο στο οποίο εισάγονται τα λάθη μετάδοσης στο σύστημά. Ο αποκωδικοποιητής 

ομαδοποιεί τα bits ανά ομάδες των logM bits, όπου M είναι το πλήθος των σταθμών που ο 

κβαντιστής του πομπού χώρισε το αρχικό σήματα. Τέλος το κύκλωμα ανακατασκευής του 

Αποδιαμόρφωση  Αποκωδικοποιητής 
Ψηφιακό σήμα 

Αναλογικό σήμα 

Ανακατασκευή 

σήματος (φίλτρο) 
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σήματος λαμβάνει το κβαντισμένο σήμα και χρησιμοποιώντας συνήθως ένα 

χαμηλοδιαβατό φίλτρο, ανακατασκευάζει το αρχικό σήμα. 

 

6. Πείραμα: Παλμοκωδική αποδιαμόρφωση 

Στην παρούσα εργαστηριακή άσκηση, θα προσπαθήσουμε να αποδιαμορφώσουμε το 

ψηφιακό σήμα που κατασκευάσαμε στην εργαστηριακή άσκηση 2.  

Οι δραστηριότητες που θα ακολουθήσουμε περιλαμβάνουν: 

1. Τη δημιουργία ενός νέου έργου (Project) 

2. Τον ορισμό προκαθορισμένων ρυθμίσεων συστήματος 

3. Τη δημιουργία ενός διαγράμματος συστήματος (system block) 

4.Την προσθήκη δομικών στοιχείων (blocks) στο διάγραμμα συστήματος 

5. Τον ορισμό των παραμέτρων προσομοίωσης  

6. Την προσθήκη γραφημάτων και μετρήσεων  

7. Την εκτέλεση της προσομοίωσης και την ανάλυση των αποτελεσμάτων 

 

6.1 Δημιουργία Project 
Βήμα 1ο:  Πάμε στο File > New Project 

Βήμα 2ο:  Επιλέγουμε File > Save Project As. Το παράθυρο διαλόγου Save As εμφανίζεται 

Βήμα 3ο:  Επιλέγουμε τον φάκελο στον οποίο θέλουμε να αποθηκεύσουμε το Project. 

Βήμα 4ο:  Δίνουμε μία ονομασία της επιλογής μας, π.χ. “PCM_Receiver” το νέο Project, 
στο παράθυρο διαλόγου που εμφανίζεται. Αποθηκεύουμε πατώντας Save. 

Σημείωση: Συνίσταται να αποθηκεύουμε κάθε νέο Project σε ξεχωριστό φάκελο. 

6.2 Ορισμός καθολικών ρυθμίσεων συστήματος 
Πριν δημιουργήσουμε μια προσομοίωση πρέπει να ορίσουμε τις καθολικές ρυθμίσεις του 

συστήματος. Για να τις ορίσουμε κάνουμε τα εξής βήματα: 

1. Από το οριζόντιο μενού επιλέγουμε Options > Project Options 
2. Πηγαίνουμε στην καρτέλα Global Units και επιβεβαιώνουμε ότι οι ρυθμίσεις 

αντιστοιχούν με αυτές που δίνονται στην Εικόνα 1. 
3. Πατάμε ΟΚ για να αποθηκεύσουμε τις ρυθμίσεις. 
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Εικόνα 1 – Ορισμός προκαθορισμένων ρυθμίσεων συστήματος 

6.3 Δημιουργία διαγράμματος συστήματος 
Για να δημιουργήσουμε το διάγραμμα συστήματος πάνω στο οποίο θα συνθέσουμε την 

τηλεπικοινωνιακή αλυσίδα της PCM διαμόρφωσης: 

1. Επιλέγουμε Project > Add System Diagram > New System Diagram. Εμφανίζεται το 

παράθυρο διαλόγου του νέου διαγράμματος συστήματος 

2. Πληκτρολογούμε “PCM_Rc” και πατάμε Create. Ένα παράθυρο διαγράμματος 

συστήματος εμφανίζεται στον χώρο εργασίας (workspace) και το “PCM_Rc” διάγραμμα 

συστήματος εμφανίζεται κάτω από τα System Diagrams στον πλοηγό Project (βλ. 

Εικόνα 2). 
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Εικόνα 2 – Διάγραμμα συστήματος 

 

6.4 Προσθήκη των δομικών στοιχείων (Blocks) στο διάγραμμα 

συστήματος (Ι) 
Επαναλάβετε τα βήματα της εργαστηριακής άσκησης 2 και κατασκευάστε τον PCM 

εκπομπό. 

6.5 Προσθήκη των δομικών στοιχείων (Blocks) στο διάγραμμα 

συστήματος (ΙΙ) 
Τα blocks που θα χρειαστούμε για την κατασκευή του PCM αποδιαμορφωτή είναι: 

1. Κανάλι μετάδοσης (AWGN) 

2. Κεραία λήψης (RX_ANTENNA) 

3. Αποδιαμορφωτής σήματος (D2R) 

4. Κατασκευαστής κβαντικού σήματος (B2SYM) 

5. Ανακατασκευαστής σήματος (DAC) 

6. Προσομοιωτής προσθήκης DC συνιστώσας (SCALE) 

7. Χαμηλοδιαβατό φίλτρο (LPFB) 
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6.5.1 Κανάλι μετάδοσης 
Θα χρειαστούμε ένα block το οποίο θα μας προσομοιώσει ένα κανάλι ασύρματης 

μετάδοσης. Θα επιλέξουμε ένα κανάλι γκαουσιανού θορύβου. 

Θα βρείτε το block του καναλιού στην καρτέλα Elements > System Blocks > Channels και 

επιλέγετε το model AWGN.  

 

Εικόνα 3: Το κανάλι γκαουσιανού θορύβου. 

Θέστε την παράμετρο LOSS στην τιμή 1dB. 

 
6.5.2 Κεραία Λήψης 

Η κεραία λήψης συλλέγει το εκπεμπόμενο σήμα και αποτελεί την είσοδο του 

αποκωδικοποιητή. 

Θα βρείτε το block της κεραίας λήψης στην καρτέλα Elements > System Blocks > RF Blocks > 

Antennas και επιλέγετε το model RX_ANTENNA.  

 

Εικόνα 4: Κεραία λήψης. 

 

Θέστε το κέρδος της κεραίας ANTGAIN=0dB. 

 
6.5.3 Αποδιαμορφωτής σήματος (D2R) 

Θα βρείτε το block του προσομοιωτή προσθήκης DC συνιστώσας στην καρτέλα Elements > 

System Blocks > Converters > Data Type και επιλέγετε το model R2D. 
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Εικόνα 5: Αποδιαμορφωτής σήματος. 

 

6.5.4 Κατασκευαστής κβαντικού σήματος 
Θα βρείτε το block του κατασκευαστή κβαντικού σήματος στην καρτέλα Elements > System 

Blocks > Converters > Binary και επιλέγετε το model B2SYM.  

 

Εικόνα 6: Κατασκευαστής κβαντικού σήματος. 

Θέστε το πλήθος των bits ανά λέξη = 4. 

 

6.5.5  Ανακατασκευαστής σήματος (DAC) 
Θα βρείτε το block του ανακατασκευαστή σήματος στην καρτέλα Elements > System Blocks 

> Converters > Analog – Digital και επιλέγετε το model DAC. Αφήστε τις default τιμές του 

μοντέλου ως έχουν. 

 

Εικόνα 7: Ανακατασκευαστής σήματος. 

 

6.5.6 Προσομοιωτής προσθήκης DC συνιστώσας 
Θα βρείτε το block του προσομοιωτή προσθήκης DC συνιστώσας στην καρτέλα Elements > 

System Blocks > Math Tools >και επιλέγετε το model SCALE. 
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Εικόνα 8: Προσομοιωτής προσθήκης DC συνιστώσας. 

 

 

Θέστε τις τιμές a=0, b=1 και c=0. 

 

6.5.7 Χαμηλοδιαβατό φίλτρο 
Θα βρείτε το block του χαμηλοδιαβατού φίλτρου στην καρτέλα Elements > System Blocks > 

Filters > Lowpass και επιλέγετε το model LPFB. Θέστε για συχνότητα αποκοπής FP = 10GHz. 

 

 
Εικόνα 9: Χαμηλοδιαβατό φίλτρο 

 
6.5.8 Συνδεσμολογία αλυσίδας 

Ενώστε back to back τα blocks, με την σειρά που αναφέρθηκαν παραπάνω. Θα πρέπει να 

καταλήξετε στην συνδεσμολογία που απεικονίζεται στην Εικόνα 10. 

 

Εικόνα 10: PCM δέκτης 

 

6.5.9 Σημεία μέτρησης 
Αρχικά εισάγετε 5 σημεία μέτρησης, ένα στην έξοδο του block AWGN, ένα στην έξοδο του 

block R2D, ένα στην έξοδο του block SCALE και ένα στην έξοδο του χαμηλοδιαβατού 

φίλτρου. Στα σημεία μέτρησης θέστε Time Span = 5ns. 

Τοποθετήστε επίσης ένα σημείο μέτρησης στο αρχικό σήμα εισόδου του πομπού (μετά το 

block SCALE δηλαδή). 
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Εκτελέστε την προσομοίωση. Τα αναμενόμενα αποτελέσματα απεικονίζονται στις εικόνες 

11 - 14. 

 

Εικόνα 11: Σύγκριση σήματος εισόδου και εξόδου του AWGN. 

 

Εικόνα 12: Σύγκριση σήματος εισόδου και εξόδου του R2D. 
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Εικόνα 13 – Σύγκριση σήματος εισόδου και εξόδου του SCALE. 

 

 

 

Εικόνα 14 – Σύγκριση σήματος εισόδου και εξόδου του χαμηλοδιαβατού φίλτρου. 
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7. Δραστηριότητες 

1. Μεταβάλλετε την τιμή του θορύβου στο κανάλι AWGN από 1 σε 2, 3, 4 και 5 dB. Τι 

παρατηρείτε στα διαγράμματα σας; 

2. Μεταβάλλετε την τιμή BITSYM του κατασκευαστή κβαντικού σήματος. Θέστε τις τιμές 1, 

2, 4, 8 και 16 διαδοχικά. Τι παρατηρείτε; 

 
 

8. Λίστα ελέγχου γνώσεων 

Αφού ολοκληρώσατε την εκτέλεση της παρούσας εργαστηριακής άσκησης, επιστρέψτε στα 
αρχικά προσδοκώμενα αποτελέσματα και ελέγξτε κατά πόσο: 

 Γνωρίζετε τα δομικά τμήματα ενός PCM δέκτη; 

 Μπορείτε να παραμετροποιήσετε τις παραμέτρους των τμημάτων ενός PCM 
εκπομπού; 

 Μπορείτε να λάβετε μετρήσεις σε όποιο σημείο επιθυμείτε από την 
τηλεπικοινωνιακή αλυσίδα PCM; 

 Μπορείτε να προσομοιώνετε την λειτουργία ενός PCM αποδιαμορφωτή; 

 

9. Βιβλιογραφία-Οδηγός για περαιτέρω μελέτη 
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[2] Jayant N .S. and Noll P. (1984), Digital Coding of Waveforms: Principles and Applications 
to Speech and Video, Prentice Hall 

[3] Proakis J. G. and Salehi M. (2008), Digital Communications (5th Ed.), McGraw-Hill Higher 
Education 

[4] Prandoni P. and Vetterli M. (2008), Signal Processing for Communications, EPFL Press 
(http://www.sp4comm.org/getit.html) 

 

10. Χρήσιμοι σύνδεσμοι 

1. https://awrcorp.com/download/faq/english/docs/Getting_Started/ 

2. http://www.awrcorp.com/awrtv-player  

3. https://en.wikipedia.org/wiki/Amplitude_modulation 
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