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1. Επισκοπηση Διεπαφης 

Το PyroSim ειναι ενα γραφικο περιβαλλον για τον προσομοιωτη δυναμικης πυρκαγιας (FDS), που 
αναπτυχθηκε απο την Thunderhead Engineering. Απλοποιει τη δημιουργια μοντελων, την 
εκτελεση και την επεξεργασια αποτελεσματων χωρις να απαιτειται χειροκινητη συγγραφη αρχειων 
εισοδου FDS. Η ενοτητα αυτη περιγραφει τις κυριες περιοχες της διεπαφης και τις συμβασεις 
πλοηγησης. 

 

1.1 Διαταξη Κυριου Παραθυρου 

Ο χωρος εργασιας του PyroSim χωριζεται σε πεντε κυριες περιοχες: 

Περιοχη Σκοπος 

Γραμμη Μενου Προσβαση σε ολες τις εντολες: File, Edit, Model, 
Simulation, Results, Help. 
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Περιοχη Σκοπος 

Γραμμη Εργαλειων Εικονιδια γρηγορης προσβασης για δημιουργια 
πλεγματος, ελεγχο προβολης, εκτελεση/παυση 
και αποτελεσματα. 

Πλοηγητης Μοντελου Δεντρικο πανελ (αριστερα) που παραθετει ολα τα 
αντικειμενα: Πλεγματα, Επιφανειες, Συσκευες, 
Αεραγωγους, Εμποδια. 

Προβολη 3D Κεντρικο παραθυρο. Υποστηριζει προοπτικες και 
ορθογραφικες προβολες. 

Πινακας Ιδιοτητων Πανελ με βαση τα συμφραζομενα (δεξια/κατω) 
που εμφανιζει τα χαρακτηριστικα του επιλεγμενου 
αντικειμενου. 

Γραμμη Κατασταση Εμφανιζει χρονο προσομοιωσης, αριθμο κελιων, 
ενεργο πλεγμα και συντεταγμενες δεικτη. 

 

1.2 Πλοηγηση στο Παραθυρο 3D 

• Μεσαιο πληκτρο ποντικιουΠεριστροφη: κρατηστε πατημενο το  

• Μετατοπιση: Shift + μεσαιο πληκτρο ποντικιου 

• Μεγεθυνση: τροχος κυλισης η Ctrl + μεσαιο ποντικι 

• FΕστιαση επιλογης: πατηστε  

• AΕστιαση ολων: πατηστε  

• View → Standard ViewsΕναλλαγη σε ορθογραφικες προβολες μεσω  

 

Συμβουλή: Χρησιμοποιηστε το View → Show/Hide για εναλλαγη πλεγματος, ετικετων αξονων και 
οριων πλεγματος FDS κατα τη ρυθμιση μοντελου. 

 

1.3 Πλοηγητης Μοντελου 

Το δεντρο Πλοηγητη αντικατοπτριζει τις ομαδες namelist του FDS. Η αναπτυξη μιας ομαδας 
αποκαλυπτει τα επιμερους αντικειμενα. Με δεξι κλικ σε οποιονδηποτε κομβο ανοιγει ενα μενου 
περιεχομενου με επιλογες Προσθηκη, Επεξεργασια, Αντιγραφη η Διαγραφη. Η αναδιαταξη με 
σερσιμο-και-αποθεση υποστηριζεται εντος της ιδιας ομαδας. 

 

1.4 Αναφορα Συντομευσεων Πληκτρολογιου 

Συντομευση Ενεργεια Συντομευση 

Ctrl + N Νεο Μοντελο Ctrl + Z / Y — Αναιρεση / 
Επαναφορα 
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Συντομευση Ενεργεια Συντομευση 

Ctrl + O Ανοιγμα Μοντελου Ctrl + D — Αντιγραφη 
Αντικειμενου 

Ctrl + S Αποθηκευση Del — Διαγραφη Επιλογης 

Ctrl + R Εκτελεση Προσομοιωσης Ctrl + A — Επιλογη Ολων 

Ctrl + Shift + R Διακοπη Προσομοιωσης F5 — Ανανεωση 
Αποτελεσματων 

 
 

2. Ρυθμιση Σεναριου Πυρκαγιας 

Ενα σωστα ρυθμισμενο σεναριο πυρκαγιας απαιτει τεσσερα βασικα συστατικα: γεωμετρια 
μοντελου, διακριτοποιηση πλεγματος, παραμετρους χρονου/φυσικης προσομοιωσης και οριακες 
συνθηκες. Η παρακατω ροη εργασιας καθοδηγει χρηστες με υπαρχουσα εμπειρια FDS σε αυτα 
τα βηματα στο PyroSim. 

 

2.1 Δημιουργια Νεου Μοντελου 

1. Εκκινηστε το PyroSim και επιλεξτε File → New Model (Ctrl + N). 

2. Στο παραθυρο διαλογου Μοντελου, εισαγετε ενα περιγραφικο ονομα και επιλεξτε 
κατευθυνομενο φακελο εργασιας. 

3. Ορισμος μοναδων (συνισταται SI) μεσω Edit → Preferences → Units. 

4. Ρυθμιστε το χρονο προσομοιωσης μεσω Model → Simulation Parameters → Time. 

 

Συμβουλή: Αποθηκευετε νωρις και συχνα. Το PyroSim αποθηκευει αυτοματα σε αρχειο .bak αλλα οι 
χειροκινητες αποθηκευσεις προστατευουν σημεια ελεγχου. 

 

2.2 Ορισμος Γεωμετριας (Εμποδια) 

Τα εμποδια στο PyroSim αντιστοιχουν απευθειας στις λιστες ονοματων FDS &OBST. 
Χρησιμοποιηστε τη γραμμη εργαλειων η το Model → New Obstruction για τοποθετηση 
γεωμετριας. 

• Εισαγωγη συντεταγμενων: πληκτρολογηστε τιμες στα πεδια XB η σερετε τις λαβες στην 
προβολη 3D. 

• Αναθεστε επιφανεια απο το μενου Surface (πρεπει να οριστει πρωτα — βλ. Ενοτητα 4). 

• Χρησιμοποιηστε ομαδες για οργανωση τοιχων, δαπεδων και οροφων για ευκολοτερη 
επιλογη και εξαγωγη. 

• Ενεργοποιηστε τη γεωμετρια Hole (Model → New Hole) για αφαιρεση ανοιγματων απο 
εμποδια για πορτες και παραθυρα. 
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2.3 Ρυθμιση Πλεγματος 

Η ποιοτητα πλεγματος ειναι ο πιο σημαντικος παραγοντας για την ακριβεια αποτελεσματων και 
την ταχυτητα προσομοιωσης. Το PyroSim παρεχει Οδηγο Πλεγματος για βοηθεια στην επιλογη 
μεγεθους κελιου. 

• Ανοιξτε τον Οδηγο Πλεγματος μεσω Model → Mesh → Mesh Wizard. 

• Ορισμος του οριου πλεγματος ωστε να περικλειει πληρως ολα τα εμποδια και πηγες 
πυρκαγιας με αποσταση τουλαχιστον 1-2 χαρακτηριστικων διαμετρων πυρκαγιας. 

• Στοχευστε σε μεγεθος κελιου κοντα στο D*/10 οπου D* ειναι η χαρακτηριστικη διαμετρος 
πυρκαγιας (D* = (Q / ro*Cp*T*sqrt(g))^(2/5)). 

• Χρησιμοποιηστε πολλαπλα μπλοκ πλεγματος (παραλληλο FDS) για μεγαλα πεδια· 
βεβαιωθειτε οτι τα πλεγματα ειναι συνεπιπεδα και στοιχισμενα στα ορια. 

 

Σημείωση: Αποφυγετε λογους διαστασεων κελιων πλεγματος μεγαλυτερους απο 2:1. Τα επιμηκη 
κελια μειωνουν την ακριβεια σε περιοχες με ισχυρη ανωστικη ροη. 

 

2.4 Παραμετροι Προσομοιωσης 

Παραμετρος Θεση στο PyroSim Τυπικη Τιμη 

Χρονος Ληξης Προσομοιωσης Model → Simulation Parameters 
→ Time 

60-600 s (αναλογα με σεναριο) 

Θερμοκρασια Περιβαλλοντος Model → Simulation Parameters 
→ Misc 

20 °C 

Διανυσμα Βαρυτητας Model → Simulation Parameters 
→ Misc 

-9.81 m/s2 (Z) 

Μοντελο Τυρβης Model → Simulation Parameters 
→ Combustion 

Deardorff (προεπιλογη) 

Κλασμα Ακτινοβολιας (Xr) Model → Simulation Parameters 
→ Combustion 

0.35 (προεπιλογη) 

Διαστημα Εξοδου Model → Output → Global 
Settings 

1-5 s 

 

2.5 Προσθηκη Αναφλεξης / Αντικειμενων Πυρκαγιας 

Το PyroSim μοντελοποιει πηγες πυρκαγιας ως επιφανειες με καθορισμενο ρυθμο αποδεσμευσης 
θερμοτητας ανα μοναδα εμβαδου (HRRPUA) η ως αεραγωγους καυστηρα. Ανατρεξτε στην 
Ενοτητα 3 (Υλικα & Καυστηρες) για δημιουργια επιφανειων. Για συνδεση επιφανειας πυρκαγιας: 

5. Επιλεξτε την εδρα εμποδιου η τον αεραγωγο που αντιπροσωπευει την επιφανεια 
καυσιμου. 

6. Στον Πινακα Ιδιοτητων, ορισμος Επιφανειας στην επιφανεια καυστηρα σας. 



Οδηγος Χρηστη PyroSim 
 Για Μηχανικους με Εμπειρια FDS 

© 2025 Οδηγος Χρηστη PyroSim 
 Σελιδα 5 απο 13 

7. Επαληθευστε οτι η κανονικη εδρας δειχνει προς τον ελευθερο χωρο (το κοκκινο βελος 
πρεπει να δειχνει προς τα εξω). 

8. Χρησιμοποιηστε Model → Time History για ορισμο σταδιακου προφιλ HRR στο χρονο 
αν χρειαζεται. 

 
 

3. Υλικα & Καυστηρες 

Το PyroSim οργανωνει τις εισοδους καυσης μεσω των συστηματων Επιφανειων και Υλικων. Οι 
επιφανειες ορισμος οριακων συνθηκων που εφαρμοζονται σε εδρες εμποδιων· τα Υλικα ορισμος 
θερμοφυσικων ιδιοτητων και ιδιοτητων πυρολυσης. 

 

3.1 Ορισμος Επιφανειας Καυστηρα (HRRPUA) 

9. Πλοηγηθειτε στο Model → Surfaces → New Surface. 

10. Επιλεξτε τυπο: Burner (Καυστηρας). 

11. Εισαγετε HRRPUA (kW/m2) — τιμη 250-500 kW/m2 ειναι συνηθισμενη για πυρκαγιες 
λιμνης. 

12. Προαιρετικα ορισμος προφιλ χρονου-HRR RAMP_Q στην καρτελα Ramp. 

13. Αναθεστε αντιδραση (ειδος καυσιμου) στην καρτελα Combustion. 

 

Συμβουλή: Για πολυπλοκες καμπυλες αναπτυξης πυρκαγιας (αναπτυξη t2), χρησιμοποιηστε 
RAMP_Q με χρονικες τιμες που αντιστοιχουν στην επιθυμητη φαση αναπτυξης. 

 

3.2 Στρωματωμενες Στερεες Επιφανειες (Πυρολυση) 

Το PyroSim υποστηριζει πολυστρωματικες στερεες επιφανειες για λεπτομερη μοντελοποιηση 
πυρολυσης (FDS &MATL και &SURF με LAYERS). Αυτο ειναι κατασκευο για καυση 
συμπυκνωμενης φασης, σχηματισμο ανθρακα η αλλεπικοιωτα επιστρωματα. 

• Προσθηκη στρωσεων μεσω της καρτελας Layers στον επεξεργαστη Επιφανειας. Καθε 
στρωση αναφερεται σε ενα Υλικο. 

• Ορισμος Υλικων στο Model → Materials → New Material. Ορισμος πυκνοτητας (kg/m3), 
ειδικης θερμοτητας (kJ/kg/K), αγωγιμοτητας (W/m/K) και αντιδρασεων πυρολυσης. 

• Για πυρολυση: ορισμος Ονοματος Αντιδρασης, A (προ-εκθετικης), E (ενεργειας 
ενεργοποιησης), Nu_Fuel και Nu_Residue. 

 

3.3 Συνοψη Κοινων Τυπων Επιφανειων 
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Τυπος Επιφανειας Ισοδυναμο FDS Namelist Τυπικη Χρηση 

Αδρανης (Inert) &SURF (προεπιλογη) Τοιχοι, οροφες, μη αντιδρωντα 
στερεα 

Καυστηρας (Burner) &SURF HRRPUA Πυρκαγιες λιμνης, καθορισμενες 
πηγες HRR 

Στρωματωμενο (Πυρολυση) &SURF + &MATL LAYERS Επιπλα, καλωδια, δομικα 
στοιχεια 

Αγωγος Παροχης/Αναρροφησης &SURF + &VENT Μηχανικη παροχη η 
αναρροφηση αερα 

Ανοιχτο (Περιβαλλον) &SURF OPEN Ορια πεδιου ανοιχτα στην 
ατμοσφαιρα 

Καθρεφτης (Mirror) &SURF MIRROR Επιπεδα συμμετριας 

Καθορισμενη Θερμοκρασια &SURF TMP_FRONT Θερμαινομενοι τοιχοι, οριακες 
συνθηκες 

 

3.4 Προβολη & Επεξεργασια Εισοδου FDS 

Ανα πασα στιγμη μπορειτε να επιθεωρησετε το ακατεργαστο αρχειο εισοδου FDS μεσω 
Simulation → FDS Input File. Αυτο ειναι πολυτιμο για επαληθευση οτι οι ορισμοι επιφανειας και 
υλικων αντιστοιχουν στην αναμενομενη συνταξη namelist. Το PyroSim διατηρει αυτο το αρχειο 
συγχρονισμενο με την κατασταση GUI σε πραγματικο χρονο. 

 
 

4. Εξαερισμος & HVAC 

Ο εξαερισμος επηρεαζει σημαντικα τη μεταφορα καπνου, τη διαθεσιμοτητα οξυγονου και την 
αποδεσμευση θερμοτητας. Το PyroSim εκθετει τον εξαερισμο FDS μεσω Vents (απλα ανοιγματα) 
και του υπο-μοντελου HVAC για δικτυα αγωγων. 

 

4.1 Απλοι Αεραγωγοι (Vents) 

Ενας Vent στο PyroSim αντιστοιχει στο FDS &VENT. Εφαρμοζει οριακη συνθηκη επιφανειας σε 
μια επιπεδη εδρα στο πεδιο, συνηθως στο οριο πλεγματος. 

14. Επιλεξτε Model → New Vent. 

15. Σχεδιασμος του ορθογωνιου vent στην αντιστοιχη εδρα οριου πλεγματος. 

16. Αναθεση επιφανειας: OPEN (εισοδος/εξοδος περιβαλλοντικης πιεσης), SUPPLY 
(αναγκαστικη παροχη αερα), EXHAUST η ορισμενος καυστηρας για ανοιγματα οροφης. 

17. Για vents παροχης, εισαγετε ογκετρικη ροη (m3/s) η ταχυτητα (m/s) και διανυσμα 
κατευθυνσης. 
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Σημείωση: Τοποθετειτε παντοτε OPEN vents στα ορια πλεγματος — η τοποθετηση τους σε 
εσωτερικες εδρες εμποδιων προκαλει σφαλματα FDS. 

 

4.2 Μοντελο Δικτυου HVAC 

Το υπο-μοντελο HVAC (FDS &HVAC, &DUCT, &NODE, &AIRCOIL, &FILTER, &FAN) επιτρεπει 
προσομοιωση υπο-πιεση συστηματων αγωγων και ελεγχο καπνου. Προσβαση μεσω Model → 
HVAC. 

• Οι κομβοι αντιπροσωπευουν διασταυρωσεις — τοποθετηστε τους σε διασταυρωσεις 
αγωγων, εισοδους/εξοδους ανεμιστηρα και εξωτερικες συνδεσεις. 

• Οι αγωγοι συνδεουν ζευγη κομβων· ορισμος υδραυλικης διαμετρου, μηκους και 
συντελεστη απωλειων. 

• Οι ανεμιστηρες ορισμος καμπυλων ροης-πιεσης (Model → HVAC → Fans). 

• Τα Aircoils και Filters μπορουν να αντιπροσωπευουν εναλλακτες θερμοτητας και φιλτρα 
σωματιδιων. 

 

4.3 Ροη Εργασιας Ρυθμισης HVAC 

18. Ορισμος ολων των κομβων HVAC (Model → HVAC → Nodes) και αναθεση εξωτερικων 
κομβων σε θεσεις vent πλεγματος. 

19. Συνδεση κομβων με αγωγους (Model → HVAC → Ducts). Εισαγωγη διαμετρου και 
τραχυτητας. 

20. Προσθηκη καμπυλων ανεμιστηρα σε κατασκευους κομβους (Model → HVAC → Fans). 

21. Συνδεση κομβων HVAC σε φυσικα vents μεσω του επεξεργαστη Vent: ορισμος 
Επιφανειας στον αντιστοιχο κομβο HVAC. 

22. Εκτελεση ελεγχου μονιμης κατασταση μεσω Simulation → Check HVAC πριν την πληρη 
προσομοιωση. 

 

4.4 Φυσικος Εξαερισμος 

Για κτιρια με φυσικο εξαερισμο (χωρις μηχανικα συστηματα), χρησιμοποιηστε OPEN επιφανεια 
vents σε παραθυρα, πορτες και ανοιγματα οροφης. Το PyroSim χειριζεται αυτοματα την 
αμφιδρομη ροη μεσω OPEN vents. Για πιο ακριβη μοντελοποιηση φαινομενου καπναγωγου: 

• Βεβαιωθειτε οτι το πεδιο εκτεινεται τουλαχιστον μια χαρακτηριστικη διαστατη πεδιο 
πεδιου πεδιο πεδιο πεδιο. 

• Εφαρμογη κλιση πιεσης περιβαλλοντος μεσω Model → Simulation Parameters → 
Pressure αν ο ανεμος ειναι σχετικος. 

• Εξετασμος προφιλ ανεμου (ορια εισοδου με RAMP_V) για σεναρια εξωτερικης 
πυρκαγιας. 
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5. Εκτελεση Προσομοιωσεων & Αναθεωρηση 
Αποτελεσματων 

Μολις το μοντελο ρυθμιστει πληρως, το PyroSim συντονιζει τον επιλυτη FDS και παρεχει 
ολοκληρωμενη μεταεπεξεργασια μεσω ενσωματωσης Smokeview και του δικου του 
προγραμματος προβολης αποτελεσματων. 

 

5.1 Ελεγχοι Πριν την Εκτελεση 

Πριν την εκκινηση προσομοιωσης, εκτελεστε τους παρακατω ελεγχους: 

• Model → Check FDS Input: επικυρωση ευθυγραμμισης πλεγματος, αναθεσεων 
επιφανειας και συνταξης namelist. 

• Αναθεωρηστε τον αριθμο κελιων στη Γραμμη Κατασταση. Στοχευστε σε ≤5 εκατομμυρια 
κελια ανα πυρηνα υπολογιστη για διαχειρισιμους χρονους εκτελεσης. 

• Επιβεβαιωστε οτι οι ποσοτητες εξοδου ειναι ορισμενες (βλ. 5.3) — οι απουσιαζουσες 
εξοδοι δεν μπορουν να ανακτηθουν μετα την εκτελεση. 

• Αποθηκευστε αντιγραφο με εκδοση του αρχειου .psm πριν απο καθε κυρια εκτελεση. 

 

5.2 Εκκινηση και Παρακολουθηση 

23. Κλικ στο Simulation → Run FDS (Ctrl + R) η κλικ στο κουμπι Εκτελεση στη γραμμη 
εργαλειων. 

24. Επιλεξτε τον αριθμο MPI διεργασιων (μια ανα μπλοκ πλεγματος για παραλληλες 
εκτελεσεις). 

25. Ο διαλογος Κατασταση Προσομοιωσης εμφανιζει την προοδο σε πραγματικο χρονο: 
χρονος προσομοιωσης, βημα χρονου (Δt) και εκτιμωμενη ολοκληρωση. 

26. Παρακολουθηστε το αρχειο .err για προειδοποιησεις FDS: υπερβολικα σφαλματα 
ταχυτητας (>1e-4), προειδοποιησεις απεκκλισης και προβληματα οριου πλεγματος. 

 

Σημείωση: Το FDS εκτυπωνει προειδοποιηση σταθεροτητας βηματος χρονου αν CFL > 1. Μειωστε 
μεγεθος κελιου πλεγματος η αυξηστε αριθμο διεργασιων αν αυτο συνεχιζεται. 

 

5.3 Ορισμος Ποσοτητων Εξοδου 

Οι ποσοτητες εξοδου πρεπει να καθοριζονται πριν την εκτελεση. Πλοηγηθειτε στο Model → 
Output: 
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Τυπος Εξοδου FDS Namelist Κοινες Ποσοτητες 

Αρχεια Τομης &SLCF Θερμοκρασια, ταχυτητα, O2, 
CO, αιθαλη 

Αρχεια Οριου &BNDF Θερμοκρασια τοιχου, ροη 
θερμοτητας, ρυθμος καυσης 

Συσκευες (Σημειο) &DEVC Θερμοκρασια, HRR, 
ενεργοποιηση καταιονητηρα 

Ισοεπιφανειες &ISOF Ισοεπιφανεια θερμοκρασιας, 
ορατοτητα καπνου 

Εξοδος HRR &CTRL / &DEVC Συνολικος HRR συναρτησει 
χρονου 

Ιχνη Σωματιδιων &PART Σωματιδια καπνου, σταγονιδια 
νερου 

 

5.4 Μεταεπεξεργασια στα Αποτελεσματα PyroSim 

Μετα την ολοκληρωση της προσομοιωσης (η κατα τη διαρκεια), ανοιξτε τον προβολεα 
αποτελεσματων μεσω Results → Open Results. Τα Αποτελεσματα PyroSim ειναι τροποποιημενη 
εκδοση του Smokeview με προστιθεμενη γραφηση δεδομενων. 

• Τρισδιαστατη Οπτικοποιηση: δεξι κλικ στο παραθυρο για φορτωση αρχειων τομης, 
ισοεπιφανειων η αρχειων οριου. 

• Γραφηματα Χρονικου Ιστορικου: επιλεξτε μια η περισσοτερες εξοδους DEVC και κλικ στο 
Results → Time History για σχεδιαση τιμων στο χρονο. 

• Στιγμιοτυπο/Κινηση: χρησιμοποιηστε File → Export Animation για δημιουργια MP4 η AVI 
περιηγησεων. 

• Συζευξη εκκενωσης: αν ειναι εγκατεστημενο το Pathfinder, υπερθεση θεσεων ατομων 
στα αποτελεσματα FDS. 

 

5.5 Βασικα Αρχεια Εξοδου FDS 

Επεκταση Αρχειου Περιεχομενα 

.smv Περιγραφεας σκηνης Smokeview — ανοιξτε στον 
προβολεα αποτελεσματων 

_devc.csv Δεδομενα χρονοσειρων για ολες τις συσκευες 
(ετοιμα για φυλλο εργασιας) 

_hrr.csv Χρονοσειρα παγκοσμιου ρυθμου αποδεσμευσης 
θερμοτητας 

.sf Δεδομενα αρχειου τομης (δυαδικα) 

.bf Δεδομενα αρχειου οριου (δυαδικα) 
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Επεκταση Αρχειου Περιεχομενα 

.err / .log Μηνυματα σφαλματων και διαγνωστικα — 
αναθεωρηστε μετα απο καθε εκτελεση 

.fds Το αρχειο εισοδου FDS που δημιουργηθηκε απο 
το PyroSim 

 
 

6. Εξαγωγη & Αναφορα 

Το PyroSim παρεχει πολλαπλες διαδρομες εξαγωγης για δεδομενα μοντελου, αποτελεσματα 
προσομοιωσης και επισημα παραδοτεα αναφορων. 

 

6.1 Εξαγωγη Αρχειου Εισοδου FDS 

Το αρχειο εισοδου FDS (.fds) δημιουργειται αυτοματα στον κατευθυνομενο φακελο εργασιας. Για 
εξαγωγη αυτονομου αντιγραφου: 

27. Πλοηγηθειτε στο Simulation → FDS Input File. 

28. Κλικ στο Save As... για εγγραφη του αρχειου σε επιλεγμενη θεση. 

29. Το αρχειο ειναι απλο κειμενο και μπορει να ανοιχτει σε οποιοδηποτε επεξεργαστη 
κειμενου για χειροκινητη επιθεωρηση, αρχειοθετηση η υποβολη σε υπολογιστικο 
συμπλεγμα. 

 

Συμβουλή: Συμπεριλαβετε το αρχειο .fds σε ολα τα αρχεια εργου — ειναι το κυριο τεκμηριο 
αναπαραγωγιμοτητας. 

 

6.2 Εξαγωγη Γεωμετριας 

Το PyroSim μπορει να εξαγει τη τρισδιαστατη γεωμετρια ανεξαρτητα απο το αρχειο FDS για 
αναθεωρηση CAD η ομοτιμη επαληθευση: 

• File → Export → DXF — Σχεδιο 2D με περιγραμματα εμποδιων και θεσεις vents. 

• File → Export → FBX / OBJ — Τρισδιαστατο πλεγμα κατασκευο για αναθεωρηση σε 
Autodesk Navisworks η Blender. 

• File → Export → IFC — Περιορισμενη εξαγωγη BIM (επαληθευστε αντιστοιχιση 
στοιχειων πριν υποβολη). 

 

6.3 Εξαγωγη Δεδομενων Αποτελεσματων 

Εξοδοι συσκευων σε _devc.csv και _hrr.csv ειναι ετοιμες για εισαγωγη σε Excel, Python (pandas) 
η R. Για γραφικα αποτελεσματα: 
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• Στιγμιοτυπο: στον προβολεα αποτελεσματων, πατηστε PrtSc η χρησιμοποιηστε File → 
Save Image. 

• Κινηση Τομης/Ισοεπιφανειας: Results → Export Animation (απαιτει εγκατεσταμενο η 
ενσωματωμενο FFmpeg). 

• Εξαγωγη CSV Τομης: τριτο εργαλειο fds2ascii (συμπεριλαμβανεται στην εγκατασταση 
FDS) μετατρεπει δυαδικα αρχεια τομης σε ASCII. 

 

6.4 Δημιουργια Αναφορας 

Το PyroSim δεν περιλαμβανει εγγενη γεννητορα αναφορων. Η συνιστωμενη ροη εργασιας για 
παραγωγη τεχνικων αναφορων ειναι: 

30. Εξαγωγη βασικων γραφηματων χρονικου ιστορικου απο Αποτελεσματα ως εικονες 
PNG. 

31. Εξαγωγη πινακων μεγιστων τιμων απο _devc.csv σε φυλλο εργασιας. 

32. Καταγραφη καρεων τρισδιαστατης οπτικοποιησης (θερμοκρασια, καπνος, ισοεπιφανεια 
HRR) σε κρισιμους χρονους. 

33. Συγκεντρωση ευρηματων σε δομημενο εγγραφο αναφορας, με αναφορα στα 
αρχειοθετημενα αρχεια .psm και .fds για ελεγξιμοτητα. 

 

Συμβουλή: Επισημανετε καθε εξαγομενη εικονα με ονομα σεναριου, χρονο προσομοιωσης και 
ποσοτητα για αποφυγη συγχυσης στις αναφορες. 

 

6.5 Βελτιστες Πρακτικες Αρχειοθετησης 

Στοιχειο Αρχειου Σκοπος 

model.psm Αρχειο εργου PyroSim — επαναφορτωνει 
ακριβως τη διεπαφη 

model.fds Αρχειο εισοδου FDS — εκτελεση ανεξαρτητα 

model_devc.csv Ολες εξοδοι συσκευων για μετα-αναλυση 

model_hrr.csv Παγκοσμια καμπυλη HRR 

model.smv + *.sf/*.bf Δεδομενα οπτικοποιησης για προβολεα 
αποτελεσματων 

model.err + model.log Διαγνωστικα — απαραιτητα για ελεγχο QA 

Στιγμιοτυπα / κινησεις Οπτικη τεκμηριωση για αναφορες 

 
 

Παραρτημα Α — Αντιμετωπιση Κοινων Προβληματων 
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Προβλημα Συνιστωμενη Ενεργεια 

Η προσομοιωση διακοπτεται αμεσως Ελεγξτε το αρχειο .err για γραμμες FDS ERROR. 
Συνηθεις αιτιες: επικαλυψη πλεγματος, OPEN 
vent εκτος οριου, αδιοριστη επιφανεια. 

Πολυ μικρα βηματα χρονου (Δt < 0.001 s) Ελεγξτε μεγιστη ταχυτητα στην εξοδο. Μειωστε 
HRRPUA η βελτιωστε πλεγμα κοντα στην πηγη 
πυρκαγιας. 

Θερμοκρασια μη ρεαλιστικα υψηλη Ελεγξτε παραμετρους καυσης (Xr, Cp). 
Επαληθευστε οτι μοναδες HRRPUA ειναι kW/m2, 
οχι W/m2. 

Ο καπνος εξαφανιζεται αμεσως Βεβαιωθειτε οτι η αποδοση αιθαλης > 0 στην 
επιφανεια καυστηρα. Ελεγξτε SOOT_YIELD στην 
εισοδο FDS. 

Το HVAC δεν ενεργοποιειται Επαληθευστε οτι οι κομβοι HVAC ειναι 
συνδεδεμενοι σε vents. Ελεγξτε καμπυλη FAN — 
βεβαιωθειτε οτι το σημειο λειτουργιας ειναι εντος 
ευρους καμπυλης. 

Ο προβολεας αποτελεσματων ειναι κενος Επιβεβαιωστε οτι το αρχειο .smv ειναι στον ιδιο 
κατευθυνομενο με τα αρχεια .sf και .bf. 
Επαναφορτωστε μεσω Results → Open Results. 

Σφαλματα ταχυτητας οριου πλεγματος Προσθηκη πλεγματος buffer περα απο ανοιχτα 
ορια. Χρησιμοποιηστε OPEN vents σε ολα τα 
ορια πλεγματος που κοιτουν προς τα εξω. 

 

Παραρτημα Β — Γρηγορη Αναφορα: Υπολογισμος D* 

Η χαρακτηριστικη διαμετρος πυρκαγιας D* καθοδηγει αποφασεις μεγεθυνσης πλεγματος. 
Υπολογιζεται ως: 

D* = ( Q / ( ro_inf · Cp · T_inf · sqrt(g) ) )^(2/5) 

 
Οπου: 
  Q      = συνολικος ρυθμος αποδεσμευσης θερμοτητας [kW] 
  ro_inf = πυκνοτητα αμβλυντος αερα [~1.2 kg/m3] 
  Cp     = ειδικη θερμοτητα αερα [~1.0 kJ/kg·K] 
  T_inf  = θερμοκρασια περιβαλλοντος [~293 K] 
  g      = επιταχυνση βαρυτητας [9.81 m/s2] 

 
Συνιστωμενη αναλυση πλεγματος: dx ≈ D* / 10  (λεπτο) 
                                  dx ≈ D* / 16  (πολυ λεπτο) 

 

Παραρτημα Γ — Χρησιμοι Ποροι 

• Οδηγος Χρηστη FDS — https://pages.nist.gov/fds-smv/ 
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• Εγχειριδιο Χρηστη PyroSim — https://support.thunderheadeng.com/docs/pyrosim/ 

• Υποστηριξη Thunderhead Engineering — https://support.thunderheadeng.com/ 

• Ομαδα Συζητησης FDS-SMV — https://groups.google.com/g/fds-smv 

• SFPE Handbook of Fire Protection Engineering — αναφορα για συσχετισμους 
αναπτυξης πυρκαγιας 
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